MATLAB: How to simplify the name of component’s ports when importing an ARXML file in SIMULINK

arxmlport namesimulink

When importing a composition or a component from an ARXML file, Simulink uses the following format for port naming: <name_of_port>_<name_of_variable>_<read|write>.
I want to systematically simplify this naming by displaying only <name_of_variable>
How can I configure simulink for this?

Best Answer

As far as I know, port naming is build-in into AUTOSAR toolbox and can not be configured or changed.
This is more or less becuase of naming convention of AUTOSAR architecture. If you generate a C- template file for your SWC from authoring tool, then generated port APIs are similar name_of_port_<name_of_variable>_<read|write>.
But good thing is, the exact names are required at root level only. We can change the port names at lower hierarchy (for example inside runnable).
In my case, I use scripts to import the arxml. And after the model is created script modifies the port names in lower hierarchy (not at root level) to short names like "name_of_variable". Thses ports with short names are used further for logic implementation.